summaryrefslogtreecommitdiff
path: root/lib/Target/X86/AsmPrinter/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Lattner <sabre@nondot.org>2009-06-19 00:47:33 +0000
committerChris Lattner <sabre@nondot.org>2009-06-19 00:47:33 +0000
commit475370b036a9e355b51c899465efc00532bb3c41 (patch)
treebc3d878cc3e9f0b41b019fab9844a605de846a5b /lib/Target/X86/AsmPrinter/CMakeLists.txt
parent4e0f25b603c96ce43474441e99252c5cd88c2e2e (diff)
downloadllvm-475370b036a9e355b51c899465efc00532bb3c41.tar.gz
llvm-475370b036a9e355b51c899465efc00532bb3c41.tar.bz2
llvm-475370b036a9e355b51c899465efc00532bb3c41.tar.xz
Add some scaffolding for a new experimental asmprinter
implementation. The idea is that we want asmprinting to work by converting MachineInstrs into a new MCInst class, then the per-instruction asmprinter works on MCInst. MCInst and the new asmprinters will not depend on most of the llvm code generators. This allows building diassemblers that don't link in the whole llvm code generator. This is step #1 of many. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@73743 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/X86/AsmPrinter/CMakeLists.txt')
-rw-r--r--lib/Target/X86/AsmPrinter/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/X86/AsmPrinter/CMakeLists.txt b/lib/Target/X86/AsmPrinter/CMakeLists.txt
index dbd03d8b96..368bcaa5ce 100644
--- a/lib/Target/X86/AsmPrinter/CMakeLists.txt
+++ b/lib/Target/X86/AsmPrinter/CMakeLists.txt
@@ -2,6 +2,7 @@ include_directories( ${CMAKE_CURRENT_BINARY_DIR}/.. ${CMAKE_CURRENT_SOURCE_DIR}/
add_partially_linked_object(LLVMX86AsmPrinter
X86ATTAsmPrinter.cpp
+ X86ATTInstPrinter.cpp
X86AsmPrinter.cpp
X86IntelAsmPrinter.cpp
)