summaryrefslogtreecommitdiff
path: root/lib/Target/X86/CMakeLists.txt
diff options
context:
space:
mode:
authorPreston Gurd <preston.gurd@intel.com>2013-01-04 20:54:54 +0000
committerPreston Gurd <preston.gurd@intel.com>2013-01-04 20:54:54 +0000
commitdd30b471750aca5c652873f9a8972df162b7e5eb (patch)
tree9d8456fada6e2541f3a24cfe271493a526bd3a36 /lib/Target/X86/CMakeLists.txt
parent60507d53e7e8e6b0c537675f68204a93c3033de7 (diff)
downloadllvm-dd30b471750aca5c652873f9a8972df162b7e5eb.tar.gz
llvm-dd30b471750aca5c652873f9a8972df162b7e5eb.tar.bz2
llvm-dd30b471750aca5c652873f9a8972df162b7e5eb.tar.xz
The current Intel Atom microarchitecture has a feature whereby when a function
returns early then it is slightly faster to execute a sequence of NOP instructions to wait until the return address is ready, as opposed to simply stalling on the ret instruction until the return address is ready. When compiling for X86 Atom only, this patch will run a pass, called "X86PadShortFunction" which will add NOP instructions where less than four cycles elapse between function entry and return. It includes tests. Patch by Andy Zhang. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@171524 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/X86/CMakeLists.txt')
-rw-r--r--lib/Target/X86/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Target/X86/CMakeLists.txt b/lib/Target/X86/CMakeLists.txt
index 19912cc6bc..140c80dee4 100644
--- a/lib/Target/X86/CMakeLists.txt
+++ b/lib/Target/X86/CMakeLists.txt
@@ -25,6 +25,7 @@ set(sources
X86JITInfo.cpp
X86MCInstLower.cpp
X86MachineFunctionInfo.cpp
+ X86PadShortFunction.cpp
X86RegisterInfo.cpp
X86SelectionDAGInfo.cpp
X86Subtarget.cpp