summaryrefslogtreecommitdiff
path: root/lib/Target/X86/Utils/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Greene <greened@obbligato.org>2011-02-17 19:18:59 +0000
committerDavid Greene <greened@obbligato.org>2011-02-17 19:18:59 +0000
commit583b68f34fd9bdb6114fa48dadc8def2ec96edac (patch)
treea9231e7086e84c4a72a661ad24f2d21f58c6e84c /lib/Target/X86/Utils/CMakeLists.txt
parent034a80d065358b412cdd270e08fb6f1986e65e50 (diff)
downloadllvm-583b68f34fd9bdb6114fa48dadc8def2ec96edac.tar.gz
llvm-583b68f34fd9bdb6114fa48dadc8def2ec96edac.tar.bz2
llvm-583b68f34fd9bdb6114fa48dadc8def2ec96edac.tar.xz
[AVX] Recorganize X86ShuffleDecode into its own library
(LLVMX86Utils.a) to break cyclic library dependencies between LLVMX86CodeGen.a and LLVMX86AsmParser.a. Previously this code was in a header file and marked static but AVX requires some additional functionality here that won't be used by all clients. Since including unused static functions causes a gcc compiler warning, keeping it as a header would break builds that use -Werror. Putting this in its own library solves both problems at once. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@125765 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Target/X86/Utils/CMakeLists.txt')
-rw-r--r--lib/Target/X86/Utils/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/Target/X86/Utils/CMakeLists.txt b/lib/Target/X86/Utils/CMakeLists.txt
new file mode 100644
index 0000000000..3ad5f991c8
--- /dev/null
+++ b/lib/Target/X86/Utils/CMakeLists.txt
@@ -0,0 +1,6 @@
+include_directories( ${CMAKE_CURRENT_BINARY_DIR}/.. ${CMAKE_CURRENT_SOURCE_DIR}/.. )
+
+add_llvm_library(LLVMX86Utils
+ X86ShuffleDecode.cpp
+ )
+add_dependencies(LLVMX86Utils X86CodeGenTable_gen)