summaryrefslogtreecommitdiff
path: root/lib/Transforms/IPO/CMakeLists.txt
diff options
context:
space:
mode:
authorVictor Hernandez <vhernandez@apple.com>2009-10-24 04:23:03 +0000
committerVictor Hernandez <vhernandez@apple.com>2009-10-24 04:23:03 +0000
commit66284e063a1e46500acae48bdc0e4a00652021d1 (patch)
tree7326efcf20c334046c044082a205dc2eb1f17466 /lib/Transforms/IPO/CMakeLists.txt
parent5a850beb2e3032e6ff3474ce5317f5454060328c (diff)
downloadllvm-66284e063a1e46500acae48bdc0e4a00652021d1.tar.gz
llvm-66284e063a1e46500acae48bdc0e4a00652021d1.tar.bz2
llvm-66284e063a1e46500acae48bdc0e4a00652021d1.tar.xz
Auto-upgrade free instructions to calls to the builtin free function.
Update all analysis passes and transforms to treat free calls just like FreeInst. Remove RaiseAllocations and all its tests since FreeInst no longer needs to be raised. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@84987 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Transforms/IPO/CMakeLists.txt')
-rw-r--r--lib/Transforms/IPO/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/Transforms/IPO/CMakeLists.txt b/lib/Transforms/IPO/CMakeLists.txt
index 5c28801555..92bef3bb75 100644
--- a/lib/Transforms/IPO/CMakeLists.txt
+++ b/lib/Transforms/IPO/CMakeLists.txt
@@ -19,7 +19,6 @@ add_llvm_library(LLVMipo
PartialInlining.cpp
PartialSpecialization.cpp
PruneEH.cpp
- RaiseAllocations.cpp
StripDeadPrototypes.cpp
StripSymbols.cpp
StructRetPromotion.cpp