summaryrefslogtreecommitdiff
path: root/lib/Transforms/IPO/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Grosser <grosser@fim.uni-passau.de>2010-04-14 23:42:23 +0000
committerTobias Grosser <grosser@fim.uni-passau.de>2010-04-14 23:42:23 +0000
commita76b334d4477266f7810ab5821429eb20b522c13 (patch)
tree9048a5503e0b2a525115cc76dcb04666662b697c /lib/Transforms/IPO/CMakeLists.txt
parentd1ec11a850843bd7afff1c939b29c9d18527e966 (diff)
downloadllvm-a76b334d4477266f7810ab5821429eb20b522c13.tar.gz
llvm-a76b334d4477266f7810ab5821429eb20b522c13.tar.bz2
llvm-a76b334d4477266f7810ab5821429eb20b522c13.tar.xz
IPO needs ScalarOpts and InstCombine in its libs
The commit "Adding IPSCCP and Internalize passes to the C-bindings" introduced new dependencies for IPO. Add these to the CMAKE build as otherwise the BUILD_SHARED_LIBS=1 build fails. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@101313 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Transforms/IPO/CMakeLists.txt')
-rw-r--r--lib/Transforms/IPO/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/Transforms/IPO/CMakeLists.txt b/lib/Transforms/IPO/CMakeLists.txt
index 92bef3bb75..65483e8fed 100644
--- a/lib/Transforms/IPO/CMakeLists.txt
+++ b/lib/Transforms/IPO/CMakeLists.txt
@@ -23,3 +23,5 @@ add_llvm_library(LLVMipo
StripSymbols.cpp
StructRetPromotion.cpp
)
+
+target_link_libraries (LLVMipo LLVMScalarOpts LLVMInstCombine)