summaryrefslogtreecommitdiff
path: root/lib/Transforms/InstCombine/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Lattner <sabre@nondot.org>2010-01-05 07:18:46 +0000
committerChris Lattner <sabre@nondot.org>2010-01-05 07:18:46 +0000
commit53a19b73b5d18794c314bf93f4f3f03e5a8af1f2 (patch)
tree21fc2648ca4de5ae184505bf4a5fb0afa60b5d60 /lib/Transforms/InstCombine/CMakeLists.txt
parent248a84beb3c7f43c2bc394ff8b2ed472573f6e2b (diff)
downloadllvm-53a19b73b5d18794c314bf93f4f3f03e5a8af1f2.tar.gz
llvm-53a19b73b5d18794c314bf93f4f3f03e5a8af1f2.tar.bz2
llvm-53a19b73b5d18794c314bf93f4f3f03e5a8af1f2.tar.xz
split add/sub out to its own file. Eliminate use of
dyn_castNotVal in the X+~X transform. dyn_castNotVal is dramatic overkill for what the xform needed. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@92704 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Transforms/InstCombine/CMakeLists.txt')
-rw-r--r--lib/Transforms/InstCombine/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Transforms/InstCombine/CMakeLists.txt b/lib/Transforms/InstCombine/CMakeLists.txt
index 739ea00585..1e6594207f 100644
--- a/lib/Transforms/InstCombine/CMakeLists.txt
+++ b/lib/Transforms/InstCombine/CMakeLists.txt
@@ -1,5 +1,6 @@
add_llvm_library(LLVMInstCombine
InstructionCombining.cpp
+ InstCombineAddSub.cpp
InstCombineCasts.cpp
InstCombineCompares.cpp
InstCombineLoadStoreAlloca.cpp