summaryrefslogtreecommitdiff
path: root/lib/Transforms/Instrumentation/CMakeLists.txt
diff options
context:
space:
mode:
authorKostya Serebryany <kcc@google.com>2012-02-13 22:50:51 +0000
committerKostya Serebryany <kcc@google.com>2012-02-13 22:50:51 +0000
commit60ebb1947faed42e493179e569c5db0c01d38a2a (patch)
treebf3043d9450f0f9b8c066c74228e2b6d7581834f /lib/Transforms/Instrumentation/CMakeLists.txt
parentce9259923dd7c9f2de21a241f109b42abbdf8a9d (diff)
downloadllvm-60ebb1947faed42e493179e569c5db0c01d38a2a.tar.gz
llvm-60ebb1947faed42e493179e569c5db0c01d38a2a.tar.bz2
llvm-60ebb1947faed42e493179e569c5db0c01d38a2a.tar.xz
ThreadSanitizer, a race detector. First LLVM commit.
Clang patch (flags) will follow shortly. The run-time library will also follow, but not immediately. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@150423 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Transforms/Instrumentation/CMakeLists.txt')
-rw-r--r--lib/Transforms/Instrumentation/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Transforms/Instrumentation/CMakeLists.txt b/lib/Transforms/Instrumentation/CMakeLists.txt
index a4a1fef51f..f8dbca389e 100644
--- a/lib/Transforms/Instrumentation/CMakeLists.txt
+++ b/lib/Transforms/Instrumentation/CMakeLists.txt
@@ -6,4 +6,5 @@ add_llvm_library(LLVMInstrumentation
OptimalEdgeProfiling.cpp
PathProfiling.cpp
ProfilingUtils.cpp
+ ThreadSanitizer.cpp
)