summaryrefslogtreecommitdiff
path: root/lib/Transforms/Instrumentation/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Collingbourne <peter@pcc.me.uk>2013-08-07 22:47:18 +0000
committerPeter Collingbourne <peter@pcc.me.uk>2013-08-07 22:47:18 +0000
commit6fa33f5dd945015d79be42c5cff146e4e2b7c4f3 (patch)
treeaca6cada9d866c167084f45e21d39a6820e92dfe /lib/Transforms/Instrumentation/CMakeLists.txt
parent9c2c660e1228fe513b5940a7fb5d3a763728dcbc (diff)
downloadllvm-6fa33f5dd945015d79be42c5cff146e4e2b7c4f3.tar.gz
llvm-6fa33f5dd945015d79be42c5cff146e4e2b7c4f3.tar.bz2
llvm-6fa33f5dd945015d79be42c5cff146e4e2b7c4f3.tar.xz
DataFlowSanitizer; LLVM changes.
DataFlowSanitizer is a generalised dynamic data flow analysis. Unlike other Sanitizer tools, this tool is not designed to detect a specific class of bugs on its own. Instead, it provides a generic dynamic data flow analysis framework to be used by clients to help detect application-specific issues within their own code. Differential Revision: http://llvm-reviews.chandlerc.com/D965 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@187923 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Transforms/Instrumentation/CMakeLists.txt')
-rw-r--r--lib/Transforms/Instrumentation/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Transforms/Instrumentation/CMakeLists.txt b/lib/Transforms/Instrumentation/CMakeLists.txt
index 5e348633ca..65d41f51fe 100644
--- a/lib/Transforms/Instrumentation/CMakeLists.txt
+++ b/lib/Transforms/Instrumentation/CMakeLists.txt
@@ -1,6 +1,7 @@
add_llvm_library(LLVMInstrumentation
AddressSanitizer.cpp
BoundsChecking.cpp
+ DataFlowSanitizer.cpp
DebugIR.cpp
EdgeProfiling.cpp
GCOVProfiling.cpp