summaryrefslogtreecommitdiff
path: root/lib/Transforms/Instrumentation/CMakeLists.txt
diff options
context:
space:
mode:
authorKostya Serebryany <kcc@google.com>2012-03-14 23:22:10 +0000
committerKostya Serebryany <kcc@google.com>2012-03-14 23:22:10 +0000
commita1c45044099cf7fb4a072f1326f164706d5bb2e2 (patch)
tree930481ec4d4321df40164ad9eb2fe28180f128cd /lib/Transforms/Instrumentation/CMakeLists.txt
parent274d377ea68195989c3238fe96ce2ca812a12faf (diff)
downloadllvm-a1c45044099cf7fb4a072f1326f164706d5bb2e2.tar.gz
llvm-a1c45044099cf7fb4a072f1326f164706d5bb2e2.tar.bz2
llvm-a1c45044099cf7fb4a072f1326f164706d5bb2e2.tar.xz
[asan] rename class BlackList to FunctionBlackList and move it into a separate file -- we will need the same functionality in ThreadSanitizer
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@152753 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Transforms/Instrumentation/CMakeLists.txt')
-rw-r--r--lib/Transforms/Instrumentation/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Transforms/Instrumentation/CMakeLists.txt b/lib/Transforms/Instrumentation/CMakeLists.txt
index f8dbca389e..e4c8cf105c 100644
--- a/lib/Transforms/Instrumentation/CMakeLists.txt
+++ b/lib/Transforms/Instrumentation/CMakeLists.txt
@@ -1,6 +1,7 @@
add_llvm_library(LLVMInstrumentation
AddressSanitizer.cpp
EdgeProfiling.cpp
+ FunctionBlackList.cpp
GCOVProfiling.cpp
Instrumentation.cpp
OptimalEdgeProfiling.cpp