summaryrefslogtreecommitdiff
path: root/lib/Transforms/Instrumentation/Makefile.am
diff options
context:
space:
mode:
authorReid Spencer <rspencer@reidspencer.com>2004-10-10 22:20:40 +0000
committerReid Spencer <rspencer@reidspencer.com>2004-10-10 22:20:40 +0000
commit81f76b324e0b22731d06ed34641032de983428b1 (patch)
treef5ab87c62a167638d6b9137687453da20d09aed3 /lib/Transforms/Instrumentation/Makefile.am
parentddef0b3a6c0afe48d2eb596e0184f125c61cfe7f (diff)
downloadllvm-81f76b324e0b22731d06ed34641032de983428b1.tar.gz
llvm-81f76b324e0b22731d06ed34641032de983428b1.tar.bz2
llvm-81f76b324e0b22731d06ed34641032de983428b1.tar.xz
Initial version of automake Makefile.am file.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@16893 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Transforms/Instrumentation/Makefile.am')
-rw-r--r--lib/Transforms/Instrumentation/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/lib/Transforms/Instrumentation/Makefile.am b/lib/Transforms/Instrumentation/Makefile.am
new file mode 100644
index 0000000000..4e716557ad
--- /dev/null
+++ b/lib/Transforms/Instrumentation/Makefile.am
@@ -0,0 +1,27 @@
+#===-- lib/Transforms/Instrumentation/Makefile.am ----------*- Makefile -*--===#
+#
+# The LLVM Compiler Infrastructure
+#
+# This file was developed by Reid Spencer and is distributed under the
+# University of Illinois Open Source License. See LICENSE.TXT for details.
+#
+#===------------------------------------------------------------------------===#
+
+include $(top_srcdir)/Makefile.rules.am
+
+SUBDIRS = ProfilePaths
+
+lib_LIBRARIES = libLLVMInstrument.a
+libexec_PROGRAMS = LLVMInstrument.o
+
+MYSOURCES = \
+ BlockProfiling.cpp \
+ EdgeProfiling.cpp \
+ EmitFunctions.cpp \
+ ProfilingUtils.cpp \
+ TraceBasicBlocks.cpp \
+ TraceValues.cpp
+
+libLLVMInstrument_a_SOURCES = $(MYSOURCES)
+LLVMInstrument_o_SOURCES = $(MYSOURCES)
+LIBS=