summaryrefslogtreecommitdiff
path: root/lib/VMCore/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Wendling <isanbard@gmail.com>2012-08-03 00:30:35 +0000
committerBill Wendling <isanbard@gmail.com>2012-08-03 00:30:35 +0000
commit573e97326766359d3a9747eed7b7d47b6c33fa0f (patch)
tree673f5f53704610e9160435ff0d435e8b8e600524 /lib/VMCore/CMakeLists.txt
parente94ac8871a1ac79bece57335d2abece0feed9c02 (diff)
downloadllvm-573e97326766359d3a9747eed7b7d47b6c33fa0f.tar.gz
llvm-573e97326766359d3a9747eed7b7d47b6c33fa0f.tar.bz2
llvm-573e97326766359d3a9747eed7b7d47b6c33fa0f.tar.xz
Move the "findUsedStructTypes" functionality outside of the Module class.
The "findUsedStructTypes" method is very expensive to run. It needs to be optimized so that LTO can run faster. Splitting this method out of the Module class will help this occur. For instance, it can keep a list of seen objects so that it doesn't process them over and over again. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@161228 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/VMCore/CMakeLists.txt')
-rw-r--r--lib/VMCore/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/VMCore/CMakeLists.txt b/lib/VMCore/CMakeLists.txt
index 648ccbdf38..6a20be6f34 100644
--- a/lib/VMCore/CMakeLists.txt
+++ b/lib/VMCore/CMakeLists.txt
@@ -31,6 +31,7 @@ add_llvm_library(LLVMCore
PassRegistry.cpp
PrintModulePass.cpp
Type.cpp
+ TypeFinder.cpp
Use.cpp
User.cpp
Value.cpp