summaryrefslogtreecommitdiff
path: root/lib/VMCore/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2013-01-02 09:10:48 +0000
committerChandler Carruth <chandlerc@gmail.com>2013-01-02 09:10:48 +0000
commitc2c50cdcdc19a1bca993c06d13d8cdca87083ce4 (patch)
treee46b4b6d4d44228df1e870f690506dbf296954c1 /lib/VMCore/CMakeLists.txt
parent3af932322859285988a4c53551540fc0658b2116 (diff)
downloadllvm-c2c50cdcdc19a1bca993c06d13d8cdca87083ce4.tar.gz
llvm-c2c50cdcdc19a1bca993c06d13d8cdca87083ce4.tar.bz2
llvm-c2c50cdcdc19a1bca993c06d13d8cdca87083ce4.tar.xz
Rename VMCore directory to IR.
Aside from moving the actual files, this patch only updates the build system and the source file comments under lib/... that are relevant. I'll be updating other docs and other files in smaller subsequnet commits. While I've tried to test this, but it is entirely possible that there will still be some build system fallout. Also, note that I've not changed the library name itself: libLLVMCore.a is still the library name. I'd be interested in others' opinions about whether we should rename this as well (I think we should, just not sure what it might break) git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@171359 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/VMCore/CMakeLists.txt')
-rw-r--r--lib/VMCore/CMakeLists.txt52
1 files changed, 0 insertions, 52 deletions
diff --git a/lib/VMCore/CMakeLists.txt b/lib/VMCore/CMakeLists.txt
deleted file mode 100644
index 06eab0e8f0..0000000000
--- a/lib/VMCore/CMakeLists.txt
+++ /dev/null
@@ -1,52 +0,0 @@
-add_llvm_library(LLVMCore
- AsmWriter.cpp
- Attributes.cpp
- AutoUpgrade.cpp
- BasicBlock.cpp
- ConstantFold.cpp
- Constants.cpp
- Core.cpp
- DataLayout.cpp
- DebugInfo.cpp
- DebugLoc.cpp
- DIBuilder.cpp
- Dominators.cpp
- Function.cpp
- GCOV.cpp
- GVMaterializer.cpp
- Globals.cpp
- IRBuilder.cpp
- InlineAsm.cpp
- Instruction.cpp
- Instructions.cpp
- IntrinsicInst.cpp
- LLVMContext.cpp
- LLVMContextImpl.cpp
- LeakDetector.cpp
- Metadata.cpp
- Module.cpp
- Pass.cpp
- PassManager.cpp
- PassRegistry.cpp
- PrintModulePass.cpp
- Type.cpp
- TypeFinder.cpp
- TargetTransformInfo.cpp
- Use.cpp
- User.cpp
- Value.cpp
- ValueSymbolTable.cpp
- ValueTypes.cpp
- Verifier.cpp
- )
-
-# Workaround: It takes over 20 minutes to compile with msvc10.
-# FIXME: Suppressing optimizations to core libraries would not be good thing.
-if( MSVC_VERSION LESS 1700 )
-set_property(
- SOURCE Function.cpp
- PROPERTY COMPILE_FLAGS "/Og-"
- )
-endif()
-
-add_dependencies(LLVMCore intrinsics_gen)