summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAnders Waldenborg <anders@0x63.nu>2013-10-23 15:01:23 +0000
committerAnders Waldenborg <anders@0x63.nu>2013-10-23 15:01:23 +0000
commit25b27154893e343e8160b071f6c9145aabfa8cbc (patch)
tree25c3c35c5ef844f998d17c1a761ab297b3d0c08f /test/CMakeLists.txt
parentf7b6bac2629c09b5dcdf9dd926c02490d2c81cd2 (diff)
downloadllvm-25b27154893e343e8160b071f6c9145aabfa8cbc.tar.gz
llvm-25b27154893e343e8160b071f6c9145aabfa8cbc.tar.bz2
llvm-25b27154893e343e8160b071f6c9145aabfa8cbc.tar.xz
Fix cmake dependency on llvm-c-test in test
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@193243 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index d900471d57..8704a10762 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -52,6 +52,10 @@ if( LLVM_USE_INTEL_JITEVENTS )
set(LLVM_TEST_DEPENDS ${LLVM_TEST_DEPENDS} llvm-jitlistener)
endif( LLVM_USE_INTEL_JITEVENTS )
+if( NOT MSVC )
+ set(LLVM_TEST_DEPENDS ${LLVM_TEST_DEPENDS} llvm-c-test)
+endif( NOT MSVC )
+
add_lit_testsuite(check-llvm "Running the LLVM regression tests"
${CMAKE_CURRENT_BINARY_DIR}
PARAMS llvm_site_config=${CMAKE_CURRENT_BINARY_DIR}/lit.site.cfg