summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Gibbs <andyg1001@hotmail.co.uk>2013-06-26 08:05:08 +0000
committerAndy Gibbs <andyg1001@hotmail.co.uk>2013-06-26 08:05:08 +0000
commit0259c0cde56209caf711527b4214d5ab0d3a9647 (patch)
treebae1e417340d72e238293faed31a3b7db7191a8e /tools/CMakeLists.txt
parent84bb3a2af228e0ee04d4b872cd0760f74253d3a3 (diff)
downloadllvm-0259c0cde56209caf711527b4214d5ab0d3a9647.tar.gz
llvm-0259c0cde56209caf711527b4214d5ab0d3a9647.tar.bz2
llvm-0259c0cde56209caf711527b4214d5ab0d3a9647.tar.xz
Provide bootstrap support to build only llvm+clang when using cmake.
Where a source tree is complete with lld, lldb and polly, it may not be possible to use cmake to configure build scripts if the host compiler it not capable of compiling these sub-projects. This change makes it possible to first build a bootstrap clang compiler when can then be used to build a complete llvm toolchain. An example bootstrap build sequence could be as follows: $ mkdir bootstrap $ cd bootstrap $ cmake -G 'Unix Makefiles' -DCMAKE_BUILD_TYPE:STRING=Release -DCMAKE_PREFIX_PATH:STRING=$(pwd) -DLLVM_TARGETS_TO_BUILD:STRING=host -DLLVM_INCLUDE_TOOLS:STRING=bootstrap-only ../source $ make clang # build clang only for host $ cd .. $ export CC=$(realpath bootstrap/bin)/clang $ export CXX=$(realpath bootstrap/bin)/clang++ $ mkdir final $ cd final $ cmake -G 'Unix Makefiles' ../source $ make all check-all git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@184924 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index f651d90865..e6637813cd 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -58,8 +58,11 @@ if( LLVM_ENABLE_PIC )
endif()
add_llvm_external_project(clang)
-add_llvm_external_project(lld)
-add_llvm_external_project(lldb)
-add_llvm_external_project(polly)
+
+if( NOT LLVM_INCLUDE_TOOLS STREQUAL "bootstrap-only" )
+ add_llvm_external_project(lld)
+ add_llvm_external_project(lldb)
+ add_llvm_external_project(polly)
+endif()
set(LLVM_COMMON_DEPENDS ${LLVM_COMMON_DEPENDS} PARENT_SCOPE)