summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorAnders Waldenborg <anders@0x63.nu>2013-10-23 08:10:20 +0000
committerAnders Waldenborg <anders@0x63.nu>2013-10-23 08:10:20 +0000
commit2bef1a6b25d938210547cd0f5ba4a08abdad2583 (patch)
tree3cfdde4e7dc5a2040f134392541dcaeb1cd37c01 /tools/CMakeLists.txt
parent9242b73286f050c53a26225b2a9acd14aeaa91da (diff)
downloadllvm-2bef1a6b25d938210547cd0f5ba4a08abdad2583.tar.gz
llvm-2bef1a6b25d938210547cd0f5ba4a08abdad2583.tar.bz2
llvm-2bef1a6b25d938210547cd0f5ba4a08abdad2583.tar.xz
Add llvm-c-test tool for testing llvm-c
This provides rudimentary testing of the llvm-c api. The following commands are implemented: * --module-dump Read bytecode from stdin - print ir * --module-list-functions Read bytecode from stdin - list summary of functions * --module-list-globals Read bytecode from stdin - list summary of globals * --targets-list List available targets * --object-list-sections Read object file from stdin - list sections * --object-list-symbols Read object file from stdin - list symbols (like nm) * --disassemble Read lines of triple, hex ascii machine code from stdin - print disassembly * --calc Read lines of name, rpn from stdin - print generated module ir Differential-Revision: http://llvm-reviews.chandlerc.com/D1776 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@193233 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 69c4050c91..54f849c706 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -39,6 +39,12 @@ add_llvm_tool_subdirectory(llvm-mcmarkup)
add_llvm_tool_subdirectory(llvm-symbolizer)
+if( NOT MSVC )
+ add_llvm_tool_subdirectory(llvm-c-test)
+else()
+ ignore_llvm_tool_subdirectory(llvm-c-test)
+endif( NOT MSVC )
+
add_llvm_tool_subdirectory(obj2yaml)
add_llvm_tool_subdirectory(yaml2obj)