summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2010-09-13 23:59:48 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2010-09-13 23:59:48 +0000
commit3a210e2d302758101ac06946e86027b327c7d0f3 (patch)
treee12390ee573b3d34a2b48b5aadfcb52d2b46296a /tools/CMakeLists.txt
parentbd916c54b7989ddbab373c61eb1ed2556ca44d27 (diff)
downloadllvm-3a210e2d302758101ac06946e86027b327c7d0f3.tar.gz
llvm-3a210e2d302758101ac06946e86027b327c7d0f3.tar.bz2
llvm-3a210e2d302758101ac06946e86027b327c7d0f3.tar.xz
Revert "CMake: Get rid of LLVMLibDeps.cmake and export the libraries normally."
This reverts commit r113632 Conflicts: cmake/modules/AddLLVM.cmake git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@113819 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index c4274ddf9f..7ed10e9729 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -2,6 +2,15 @@
# large and three small executables. This is done to minimize memory load
# in parallel builds. Please retain this ordering.
+if( NOT WIN32 OR MSYS OR CYGWIN )
+ # It is useful to build llvm-config before the other tools, so we
+ # have a fresh LibDeps.txt for regenerating the hard-coded library
+ # dependencies. llvm-config/CMakeLists.txt takes care of this but we
+ # must keep llvm-config as the first entry on the list of tools to
+ # be built.
+ add_subdirectory(llvm-config)
+endif()
+
add_subdirectory(opt)
add_subdirectory(llvm-as)
add_subdirectory(llvm-dis)
@@ -29,4 +38,6 @@ add_subdirectory(llvmc)
if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/clang/CMakeLists.txt )
add_subdirectory( ${CMAKE_CURRENT_SOURCE_DIR}/clang )
-endif()
+endif( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/clang/CMakeLists.txt )
+
+set(LLVM_COMMON_DEPENDS ${LLVM_COMMON_DEPENDS} PARENT_SCOPE)