summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2008-10-26 00:52:09 +0000
committerOscar Fuentes <ofv@wanadoo.es>2008-10-26 00:52:09 +0000
commit48ed0f59d5397c38baa0e4a0588e168b44e521ff (patch)
tree06300ef9556d2e80d86765bd61759f39845209c8 /tools/CMakeLists.txt
parentbcc1db5f0a0444b277967d7b78411f0d14f7ccf4 (diff)
downloadllvm-48ed0f59d5397c38baa0e4a0588e168b44e521ff.tar.gz
llvm-48ed0f59d5397c38baa0e4a0588e168b44e521ff.tar.bz2
llvm-48ed0f59d5397c38baa0e4a0588e168b44e521ff.tar.xz
CMake: If we have `clang' under the `tools/' subdirectory, add it to
the build. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@58179 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 8909cbd266..d05cb9aa93 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -30,3 +30,7 @@ add_subdirectory(bugpoint)
add_subdirectory(llvm-bcanalyzer)
add_subdirectory(llvm-stub)
add_subdirectory(llvmc2)
+
+if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/clang/CMakeLists.txt )
+ add_subdirectory( ${CMAKE_CURRENT_SOURCE_DIR}/clang )
+endif( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/clang/CMakeLists.txt )