summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2009-06-04 19:53:37 +0000
committerDouglas Gregor <dgregor@apple.com>2009-06-04 19:53:37 +0000
commit8eeb96d2d56f05fe6cf95a835f66c72410215be2 (patch)
tree019512dcfbf14306615922d944b429afbf3f5481 /tools/CMakeLists.txt
parentd8b4711a16a38f446f2d0e902d13790e03196dee (diff)
downloadllvm-8eeb96d2d56f05fe6cf95a835f66c72410215be2.tar.gz
llvm-8eeb96d2d56f05fe6cf95a835f66c72410215be2.tar.bz2
llvm-8eeb96d2d56f05fe6cf95a835f66c72410215be2.tar.xz
CMake: Use explicit dependencies for Xcode (as well as MSVC), to make
the CMake-generated Xcode project build properly. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@72883 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 113d98743c..5c1ee351a2 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -2,9 +2,9 @@
# large and three small executables. This is done to minimize memory load
# in parallel builds. Please retain this ordering.
-if( NOT MSVC )
- add_subdirectory(llvm-config)
-endif( NOT MSVC )
+if (NOT USE_EXPLICIT_DEPENDENCIES)
+ add_subdirectory(llvm-config)
+endif()
add_subdirectory(opt)
add_subdirectory(llvm-as)