summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2009-08-14 01:55:05 +0000
committerOscar Fuentes <ofv@wanadoo.es>2009-08-14 01:55:05 +0000
commit8ef01dc319e7fded113f9e2748ca0e5c2bb602d4 (patch)
tree5e0cc18ec37648db8f28cf6b1a42890cf61e4de8 /tools/CMakeLists.txt
parenta1efbbdbf3217598f334a6f39dab84ca06f5de41 (diff)
downloadllvm-8ef01dc319e7fded113f9e2748ca0e5c2bb602d4.tar.gz
llvm-8ef01dc319e7fded113f9e2748ca0e5c2bb602d4.tar.bz2
llvm-8ef01dc319e7fded113f9e2748ca0e5c2bb602d4.tar.xz
CMake: build llvm-config before the other tools.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@78975 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 5dcfebaa72..40bf692439 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -3,7 +3,12 @@
# in parallel builds. Please retain this ordering.
if( NOT MSVC )
- add_subdirectory(llvm-config)
+ # It is useful to build llvm-config before the other tools, so we
+ # have a fresh LibDeps.txt for regenerating the hard-coded library
+ # dependencies. llvm-config/CMakeLists.txt takes care of this but we
+ # must keep llvm-config as the first entry on the list of tools to
+ # be built.
+ add_subdirectory(llvm-config)
endif()
add_subdirectory(opt)