summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2009-08-16 20:50:41 +0000
committerOscar Fuentes <ofv@wanadoo.es>2009-08-16 20:50:41 +0000
commitc23a8d133c7a1a1b5467239334c664352d10d81f (patch)
tree71974afac5fd907ba279bdbb8b2b22679b9bacb2 /tools/CMakeLists.txt
parent66a39699fb6b862e674415b32d307263812e996e (diff)
downloadllvm-c23a8d133c7a1a1b5467239334c664352d10d81f.tar.gz
llvm-c23a8d133c7a1a1b5467239334c664352d10d81f.tar.bz2
llvm-c23a8d133c7a1a1b5467239334c664352d10d81f.tar.xz
CMake: Discriminate MINGW, MSYS, CYGWIN: does not try to build llvm-config under mingw without msys.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@79202 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 8c2c1a5323..51eb725616 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -2,7 +2,7 @@
# large and three small executables. This is done to minimize memory load
# in parallel builds. Please retain this ordering.
-if( NOT MSVC )
+if( NOT WIN32 OR MSYS OR CYGWIN )
# It is useful to build llvm-config before the other tools, so we
# have a fresh LibDeps.txt for regenerating the hard-coded library
# dependencies. llvm-config/CMakeLists.txt takes care of this but we