summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Dunbar <daniel@zuster.org>2011-12-01 20:18:09 +0000
committerDaniel Dunbar <daniel@zuster.org>2011-12-01 20:18:09 +0000
commitcb497b888aabebe13de431c8a6e7c7d31f4dea0c (patch)
tree94a829541665ba414539b874d82af79c00612f58 /tools/CMakeLists.txt
parentb3821996efeae84408133c92c28756c46f101658 (diff)
downloadllvm-cb497b888aabebe13de431c8a6e7c7d31f4dea0c.tar.gz
llvm-cb497b888aabebe13de431c8a6e7c7d31f4dea0c.tar.bz2
llvm-cb497b888aabebe13de431c8a6e7c7d31f4dea0c.tar.xz
llvm-config: Replace with C++ version (was llvm-config-2).
- Another reapply of r144300, with hopefully one last fix. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@145623 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index edfd3b2b71..ec0647124b 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -11,16 +11,9 @@ if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/polly/CMakeLists.txt )
endif( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/polly/CMakeLists.txt )
if( NOT WIN32 OR MSYS OR CYGWIN )
- # It is useful to build llvm-config before the other tools, so we
- # have a fresh LibDeps.txt for regenerating the hard-coded library
- # dependencies. llvm-config/CMakeLists.txt takes care of this but we
- # must keep llvm-config as the first entry on the list of tools to
- # be built.
- add_subdirectory(llvm-config)
-
- # We currently require 'sed' to build llvm-config-2, so don't try to build it
+ # We currently require 'sed' to build llvm-config, so don't try to build it
# on pure Win32.
- add_subdirectory(llvm-config-2)
+ add_subdirectory(llvm-config)
endif()
add_subdirectory(opt)