summaryrefslogtreecommitdiff
path: root/tools/lli/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Kaylor <andrew.kaylor@intel.com>2013-10-02 17:12:36 +0000
committerAndrew Kaylor <andrew.kaylor@intel.com>2013-10-02 17:12:36 +0000
commit0ab5c6c16b1b09d76c3ba2d70443b10bcc26169c (patch)
treeaf098f261c3db5f9da3efd5aa5ab1ca9e05046e0 /tools/lli/CMakeLists.txt
parentaf7ae9d6890ce5fae27e38ccebb5da09288c49e0 (diff)
downloadllvm-0ab5c6c16b1b09d76c3ba2d70443b10bcc26169c.tar.gz
llvm-0ab5c6c16b1b09d76c3ba2d70443b10bcc26169c.tar.bz2
llvm-0ab5c6c16b1b09d76c3ba2d70443b10bcc26169c.tar.xz
Adding out-of-process execution support to lli.
At this time only Unix-based systems are supported. Windows has stubs and should re-route to the simulated mode. Thanks to Sriram Murali for contributions to this patch. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@191843 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/lli/CMakeLists.txt')
-rw-r--r--tools/lli/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/lli/CMakeLists.txt b/tools/lli/CMakeLists.txt
index 98f411d07a..578c414cce 100644
--- a/tools/lli/CMakeLists.txt
+++ b/tools/lli/CMakeLists.txt
@@ -1,6 +1,8 @@
set(LLVM_LINK_COMPONENTS mcjit jit interpreter nativecodegen bitreader asmparser irreader selectiondag native instrumentation)
+add_subdirectory(ChildTarget)
+
if( LLVM_USE_OPROFILE )
set(LLVM_LINK_COMPONENTS
${LLVM_LINK_COMPONENTS}
@@ -21,4 +23,5 @@ add_llvm_tool(lli
lli.cpp
RecordingMemoryManager.cpp
RemoteTarget.cpp
+ RemoteTargetExternal.cpp
)