summaryrefslogtreecommitdiff
path: root/tools/lli/CMakeLists.txt
diff options
context:
space:
mode:
authorJim Grosbach <grosbach@apple.com>2012-11-05 19:06:05 +0000
committerJim Grosbach <grosbach@apple.com>2012-11-05 19:06:05 +0000
commit6837232a609fe7b13473606a1c8a18eabfe2df2a (patch)
treed644f239b1467567c537e897f5c074f4cbf48f3c /tools/lli/CMakeLists.txt
parent827b7a070d349737f1d6ff63115e0cbb0c031f9c (diff)
downloadllvm-6837232a609fe7b13473606a1c8a18eabfe2df2a.tar.gz
llvm-6837232a609fe7b13473606a1c8a18eabfe2df2a.tar.bz2
llvm-6837232a609fe7b13473606a1c8a18eabfe2df2a.tar.xz
lli: Initialize the native asm parser for inline assembly.
MCJIT supports inline assembly, but requires the asm parser to do so. Make sure to link it in and initialize it. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@167392 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/lli/CMakeLists.txt')
-rw-r--r--tools/lli/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/lli/CMakeLists.txt b/tools/lli/CMakeLists.txt
index a9c7adf978..ed479f5323 100644
--- a/tools/lli/CMakeLists.txt
+++ b/tools/lli/CMakeLists.txt
@@ -1,5 +1,5 @@
-set(LLVM_LINK_COMPONENTS mcjit jit interpreter nativecodegen bitreader asmparser selectiondag)
+set(LLVM_LINK_COMPONENTS mcjit jit interpreter nativecodegen bitreader asmparser selectiondag native)
if( LLVM_USE_OPROFILE )
set(LLVM_LINK_COMPONENTS