summaryrefslogtreecommitdiff
path: root/tools/lli/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Kaylor <andrew.kaylor@intel.com>2013-01-28 19:52:37 +0000
committerAndrew Kaylor <andrew.kaylor@intel.com>2013-01-28 19:52:37 +0000
commit710cb0c7826c61b432e19d5899a2f26f76d7aa81 (patch)
treeed8f79a169a0ab4360e5680008b8748b0a78ed70 /tools/lli/CMakeLists.txt
parent3c1c042a64e0d0d01c0e2817aa1f0f5c9c726a80 (diff)
downloadllvm-710cb0c7826c61b432e19d5899a2f26f76d7aa81.tar.gz
llvm-710cb0c7826c61b432e19d5899a2f26f76d7aa81.tar.bz2
llvm-710cb0c7826c61b432e19d5899a2f26f76d7aa81.tar.xz
Add support for source and line information to IntelJITEventListener for object emitted by MCJIT.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@173712 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/lli/CMakeLists.txt')
-rw-r--r--tools/lli/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/lli/CMakeLists.txt b/tools/lli/CMakeLists.txt
index ed479f5323..356233f397 100644
--- a/tools/lli/CMakeLists.txt
+++ b/tools/lli/CMakeLists.txt
@@ -11,7 +11,9 @@ endif( LLVM_USE_OPROFILE )
if( LLVM_USE_INTEL_JITEVENTS )
set(LLVM_LINK_COMPONENTS
${LLVM_LINK_COMPONENTS}
+ DebugInfo
IntelJITEvents
+ Object
)
endif( LLVM_USE_INTEL_JITEVENTS )