summaryrefslogtreecommitdiff
path: root/tools/lli/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Malea <daniel.malea@intel.com>2013-06-28 19:11:40 +0000
committerDaniel Malea <daniel.malea@intel.com>2013-06-28 19:11:40 +0000
commite16e687034fb416f9e6f90d8e169cc8633c34f35 (patch)
treeb5c4bef1c2439a526f72a5f1fdd41e6115c33fe6 /tools/lli/CMakeLists.txt
parent8e6b2974327c733edf267e971ce5f8982421a888 (diff)
downloadllvm-e16e687034fb416f9e6f90d8e169cc8633c34f35.tar.gz
llvm-e16e687034fb416f9e6f90d8e169cc8633c34f35.tar.bz2
llvm-e16e687034fb416f9e6f90d8e169cc8633c34f35.tar.xz
Add flag to lli to enable debugging of IR when used with MCJIT.
- warn users when -debug-ir is used with old JIT engine (only partial debug info is available) For example, to debug an IR file with GDB (that supports JIT registration), do: $ gdb --args lli -use-mcjit -debug-ir testcase.ll (gdb) break main (gdb) run <Process continues to lli main> (gdb) continue <Process continues to testcase.ll main() (gdb) step <Now stepping through the LLVM IR in testcase.ll> git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@185197 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/lli/CMakeLists.txt')
-rw-r--r--tools/lli/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/lli/CMakeLists.txt b/tools/lli/CMakeLists.txt
index aaa6598e71..98f411d07a 100644
--- a/tools/lli/CMakeLists.txt
+++ b/tools/lli/CMakeLists.txt
@@ -1,5 +1,5 @@
-set(LLVM_LINK_COMPONENTS mcjit jit interpreter nativecodegen bitreader asmparser irreader selectiondag native)
+set(LLVM_LINK_COMPONENTS mcjit jit interpreter nativecodegen bitreader asmparser irreader selectiondag native instrumentation)
if( LLVM_USE_OPROFILE )
set(LLVM_LINK_COMPONENTS