summaryrefslogtreecommitdiff
path: root/tools/llvm-ar/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael Espindola <rafael.espindola@gmail.com>2013-06-17 15:47:20 +0000
committerRafael Espindola <rafael.espindola@gmail.com>2013-06-17 15:47:20 +0000
commit8496faea07de27b6d3435d02855db4bfebcc2781 (patch)
tree4345703a348c3b6144793e0b7f9b2a672cadb54f /tools/llvm-ar/CMakeLists.txt
parent5cd6db9a514ccb37df20455e543c88df5594eec0 (diff)
downloadllvm-8496faea07de27b6d3435d02855db4bfebcc2781.tar.gz
llvm-8496faea07de27b6d3435d02855db4bfebcc2781.tar.bz2
llvm-8496faea07de27b6d3435d02855db4bfebcc2781.tar.xz
Move lib/Archive to tools/llvm-ar.
llvm-ar is the only tool that needs to write archive files. Every other tool should be able to use the lib/Object interface. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@184083 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-ar/CMakeLists.txt')
-rw-r--r--tools/llvm-ar/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/llvm-ar/CMakeLists.txt b/tools/llvm-ar/CMakeLists.txt
index 70eb7603fd..68095df714 100644
--- a/tools/llvm-ar/CMakeLists.txt
+++ b/tools/llvm-ar/CMakeLists.txt
@@ -1,7 +1,10 @@
-set(LLVM_LINK_COMPONENTS archive)
+set(LLVM_LINK_COMPONENTS support bitreader)
add_llvm_tool(llvm-ar
llvm-ar.cpp
+ ArchiveWriter.cpp
+ ArchiveReader.cpp
+ Archive.cpp
)
# TODO: Support check-local.