summaryrefslogtreecommitdiff
path: root/tools/llvm-diff/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Golin <renato.golin@arm.com>2011-03-14 22:22:46 +0000
committerRenato Golin <renato.golin@arm.com>2011-03-14 22:22:46 +0000
commit7d4fc4fb345ee8a1de15c718a854b5f38c1e6e46 (patch)
treec14f22bb75463ef2b5e6b2b36fb2d46c72d333c3 /tools/llvm-diff/CMakeLists.txt
parent6e70cc1f976785674d8552ff47e26cd28fbde120 (diff)
downloadllvm-7d4fc4fb345ee8a1de15c718a854b5f38c1e6e46.tar.gz
llvm-7d4fc4fb345ee8a1de15c718a854b5f38c1e6e46.tar.bz2
llvm-7d4fc4fb345ee8a1de15c718a854b5f38c1e6e46.tar.xz
This patch is a big refactoring of llvm-diff. It doesn't add new features, but it re-organizes the old features, so I can insert the MetadataEngine to use the same infrastructure.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@127627 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-diff/CMakeLists.txt')
-rw-r--r--tools/llvm-diff/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/llvm-diff/CMakeLists.txt b/tools/llvm-diff/CMakeLists.txt
index f6d65c947a..c59d69ea0d 100644
--- a/tools/llvm-diff/CMakeLists.txt
+++ b/tools/llvm-diff/CMakeLists.txt
@@ -2,5 +2,7 @@ set(LLVM_LINK_COMPONENTS support asmparser bitreader)
add_llvm_tool(llvm-diff
llvm-diff.cpp
+ DiffConsumer.cpp
+ DiffLog.cpp
DifferenceEngine.cpp
)