summaryrefslogtreecommitdiff
path: root/tools/llvm-nm/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael Espindola <rafael.espindola@gmail.com>2014-02-21 20:10:59 +0000
committerRafael Espindola <rafael.espindola@gmail.com>2014-02-21 20:10:59 +0000
commit91f86b7e1c07e73667537e6b849f9977caeeed3d (patch)
treeeec10058b9d06564ce0339282b7b202d1f76c17d /tools/llvm-nm/CMakeLists.txt
parent3825c08a609de48d5752e4d74e3c03cca651f894 (diff)
downloadllvm-91f86b7e1c07e73667537e6b849f9977caeeed3d.tar.gz
llvm-91f86b7e1c07e73667537e6b849f9977caeeed3d.tar.bz2
llvm-91f86b7e1c07e73667537e6b849f9977caeeed3d.tar.xz
Add a SymbolicFile interface between Binary and ObjectFile.
This interface allows IRObjectFile to be implemented without having dummy methods for all section and segment related methods. Both llvm-ar and llvm-nm are changed to use it. Unfortunately the mangler is still not plugged in since it requires some refactoring to make a Module hold a DataLayout. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@201881 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-nm/CMakeLists.txt')
-rw-r--r--tools/llvm-nm/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/tools/llvm-nm/CMakeLists.txt b/tools/llvm-nm/CMakeLists.txt
index ce758ced44..6128bf9adf 100644
--- a/tools/llvm-nm/CMakeLists.txt
+++ b/tools/llvm-nm/CMakeLists.txt
@@ -1,6 +1,4 @@
set(LLVM_LINK_COMPONENTS
- BitReader
- Core
Object
Support
)