summaryrefslogtreecommitdiff
path: root/tools/llvm-profdata/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Bogner <mail@justinbogner.com>2014-03-12 20:14:17 +0000
committerJustin Bogner <mail@justinbogner.com>2014-03-12 20:14:17 +0000
commit4207c6759c040ca9c26fd305b1e62d5c68a44fb1 (patch)
treebd8a82a31b229d1a27a158b93a13d15fbd9d2733 /tools/llvm-profdata/CMakeLists.txt
parent02da814a94c043452e3ad10915e8ba366218e925 (diff)
downloadllvm-4207c6759c040ca9c26fd305b1e62d5c68a44fb1.tar.gz
llvm-4207c6759c040ca9c26fd305b1e62d5c68a44fb1.tar.bz2
llvm-4207c6759c040ca9c26fd305b1e62d5c68a44fb1.tar.xz
llvm-profdata: Use the Profile library, implement show and generate
This replaces the llvm-profdata tool with a version that uses the recently introduced Profile library. The new tool has the ability to generate and summarize profdata files as well as merging them. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@203704 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-profdata/CMakeLists.txt')
-rw-r--r--tools/llvm-profdata/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/llvm-profdata/CMakeLists.txt b/tools/llvm-profdata/CMakeLists.txt
index 4b1357d87e..f0667f16f9 100644
--- a/tools/llvm-profdata/CMakeLists.txt
+++ b/tools/llvm-profdata/CMakeLists.txt
@@ -1,4 +1,4 @@
-set(LLVM_LINK_COMPONENTS core support )
+set(LLVM_LINK_COMPONENTS core profile support)
add_llvm_tool(llvm-profdata
llvm-profdata.cpp