summaryrefslogtreecommitdiff
path: root/tools/llvm-profdata/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Bogner <mail@justinbogner.com>2014-03-21 17:24:48 +0000
committerJustin Bogner <mail@justinbogner.com>2014-03-21 17:24:48 +0000
commitc0f3b725555df38fc4d9be6154af95dad83694f8 (patch)
tree9b55483376292140b20656648ed1254eebff2e83 /tools/llvm-profdata/CMakeLists.txt
parent6c22b041da771c2cccc004d97fd49543f0ebf168 (diff)
downloadllvm-c0f3b725555df38fc4d9be6154af95dad83694f8.tar.gz
llvm-c0f3b725555df38fc4d9be6154af95dad83694f8.tar.bz2
llvm-c0f3b725555df38fc4d9be6154af95dad83694f8.tar.xz
ProfileData: Introduce the InstrProfReader interface and a text reader
This introduces the ProfileData library and updates llvm-profdata to use this library for reading profiles. InstrProfReader is an abstract base class that will be subclassed for both the raw instrprof data from compiler-rt and the efficient instrprof format that will be used for PGO. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@204482 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-profdata/CMakeLists.txt')
-rw-r--r--tools/llvm-profdata/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/llvm-profdata/CMakeLists.txt b/tools/llvm-profdata/CMakeLists.txt
index 4b1357d87e..4c64cfa1fa 100644
--- a/tools/llvm-profdata/CMakeLists.txt
+++ b/tools/llvm-profdata/CMakeLists.txt
@@ -1,4 +1,4 @@
-set(LLVM_LINK_COMPONENTS core support )
+set(LLVM_LINK_COMPONENTS core profiledata support )
add_llvm_tool(llvm-profdata
llvm-profdata.cpp