summaryrefslogtreecommitdiff
path: root/tools/llvm-profdata/CMakeLists.txt
diff options
context:
space:
mode:
authorDuncan P. N. Exon Smith <dexonsmith@apple.com>2014-02-17 23:22:49 +0000
committerDuncan P. N. Exon Smith <dexonsmith@apple.com>2014-02-17 23:22:49 +0000
commitddc5a010a40a7b85a020a072f9f6b4ae132e94bd (patch)
tree147cfb9555bac4adf6f6ef5a9c5cf3a8dcf69b7e /tools/llvm-profdata/CMakeLists.txt
parent4959a2d8780bb6a2424a0bb82df45d5150cef228 (diff)
downloadllvm-ddc5a010a40a7b85a020a072f9f6b4ae132e94bd.tar.gz
llvm-ddc5a010a40a7b85a020a072f9f6b4ae132e94bd.tar.bz2
llvm-ddc5a010a40a7b85a020a072f9f6b4ae132e94bd.tar.xz
PGO: llvm-profdata: tool for merging profiles
Introducing llvm-profdata, a tool for merging profile data generated by PGO instrumentation in clang. - The name indicates a file extension of <name>.profdata. Eventually profile data output by clang should be changed to that extension. - llvm-profdata merges two profiles. However, the name is more general, since it will likely pick up more tasks (such as summarizing a single profile). - llvm-profdata parses the current text-based format, but will be updated once we settle on a binary format. <rdar://problem/15949645> git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@201535 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-profdata/CMakeLists.txt')
-rw-r--r--tools/llvm-profdata/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/llvm-profdata/CMakeLists.txt b/tools/llvm-profdata/CMakeLists.txt
new file mode 100644
index 0000000000..4b1357d87e
--- /dev/null
+++ b/tools/llvm-profdata/CMakeLists.txt
@@ -0,0 +1,5 @@
+set(LLVM_LINK_COMPONENTS core support )
+
+add_llvm_tool(llvm-profdata
+ llvm-profdata.cpp
+ )