summaryrefslogtreecommitdiff
path: root/tools/llvm-rtdyld/CMakeLists.txt
diff options
context:
space:
mode:
authorLang Hames <lhames@gmail.com>2014-06-27 20:20:57 +0000
committerLang Hames <lhames@gmail.com>2014-06-27 20:20:57 +0000
commitc3747f276a212e73119980479409281df57a8269 (patch)
tree0ef07885b61475d454088c60c249aee194e70b03 /tools/llvm-rtdyld/CMakeLists.txt
parent63195d7e5a1d8715566c5a33902885e28a8977c2 (diff)
downloadllvm-c3747f276a212e73119980479409281df57a8269.tar.gz
llvm-c3747f276a212e73119980479409281df57a8269.tar.bz2
llvm-c3747f276a212e73119980479409281df57a8269.tar.xz
[RuntimeDyld] Add a framework for testing relocation logic in RuntimeDyld.
This patch adds a "-verify" mode to the llvm-rtdyld utility. In verify mode, llvm-rtdyld will test supplied expressions against the linked program images that it creates in memory. This scheme can be used to verify the correctness of the relocation logic applied by RuntimeDyld. The expressions to test will be read out of files passed via the -check option (there may be more than one of these). Expressions to check are extracted from lines of the form: # rtdyld-check: <expression> This system is designed to fit the llvm-lit regression test workflow. It is format and target agnostic, and supports verification of images linked for remote targets. The expression language is defined in llvm/include/llvm/RuntimeDyldChecker.h . Examples can be found in test/ExecutionEngine/RuntimeDyld. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@211956 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-rtdyld/CMakeLists.txt')
-rw-r--r--tools/llvm-rtdyld/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/llvm-rtdyld/CMakeLists.txt b/tools/llvm-rtdyld/CMakeLists.txt
index 3ad127fd73..feb213489d 100644
--- a/tools/llvm-rtdyld/CMakeLists.txt
+++ b/tools/llvm-rtdyld/CMakeLists.txt
@@ -1,6 +1,8 @@
set(LLVM_LINK_COMPONENTS
+ ${LLVM_TARGETS_TO_BUILD}
DebugInfo
ExecutionEngine
+ MC
RuntimeDyld
Support
)