summaryrefslogtreecommitdiff
path: root/tools/llvm-rtdyld/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Kaylor <andrew.kaylor@intel.com>2013-01-25 22:50:58 +0000
committerAndrew Kaylor <andrew.kaylor@intel.com>2013-01-25 22:50:58 +0000
commitee7c0d2f931590ccdc53a14b1839e11bb29fc96e (patch)
tree691f74c6f15436cdeacf8fa67089c34071a00460 /tools/llvm-rtdyld/CMakeLists.txt
parentc73b7f702258b844dc2702fd9d79d8a8706460a7 (diff)
downloadllvm-ee7c0d2f931590ccdc53a14b1839e11bb29fc96e.tar.gz
llvm-ee7c0d2f931590ccdc53a14b1839e11bb29fc96e.tar.bz2
llvm-ee7c0d2f931590ccdc53a14b1839e11bb29fc96e.tar.xz
Add support for applying in-memory relocations to the .debug_line section and, in the case of ELF files, using symbol addresses when available for relocations to the .debug_info section. Also extending the llvm-rtdyld tool to add the ability to dump line number information for testing purposes.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@173517 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-rtdyld/CMakeLists.txt')
-rw-r--r--tools/llvm-rtdyld/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/llvm-rtdyld/CMakeLists.txt b/tools/llvm-rtdyld/CMakeLists.txt
index 17e2c3e2d5..8d161d366d 100644
--- a/tools/llvm-rtdyld/CMakeLists.txt
+++ b/tools/llvm-rtdyld/CMakeLists.txt
@@ -1,4 +1,4 @@
-set(LLVM_LINK_COMPONENTS ${LLVM_TARGETS_TO_BUILD} support MC object RuntimeDyld JIT)
+set(LLVM_LINK_COMPONENTS ${LLVM_TARGETS_TO_BUILD} support MC object RuntimeDyld JIT debuginfo)
add_llvm_tool(llvm-rtdyld
llvm-rtdyld.cpp