summaryrefslogtreecommitdiff
path: root/tools/llvm-stress/CMakeLists.txt
diff options
context:
space:
mode:
authorNadav Rotem <nadav.rotem@intel.com>2012-02-26 08:35:53 +0000
committerNadav Rotem <nadav.rotem@intel.com>2012-02-26 08:35:53 +0000
commitfdc309cc4e95778d7615f3829917c4fe42086e1e (patch)
tree9f6622c4fef2c99c6e56fc51139e5b43e386af03 /tools/llvm-stress/CMakeLists.txt
parenta515b4e014cfcdad8982d36cfa80b7edeca69499 (diff)
downloadllvm-fdc309cc4e95778d7615f3829917c4fe42086e1e.tar.gz
llvm-fdc309cc4e95778d7615f3829917c4fe42086e1e.tar.bz2
llvm-fdc309cc4e95778d7615f3829917c4fe42086e1e.tar.xz
Add a random .LL file generator to stress-test different llvm components.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@151479 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/llvm-stress/CMakeLists.txt')
-rw-r--r--tools/llvm-stress/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/llvm-stress/CMakeLists.txt b/tools/llvm-stress/CMakeLists.txt
new file mode 100644
index 0000000000..e2d07a5dda
--- /dev/null
+++ b/tools/llvm-stress/CMakeLists.txt
@@ -0,0 +1,5 @@
+set(LLVM_LINK_COMPONENTS bitreader asmparser bitwriter instrumentation scalaropts ipo)
+
+add_llvm_tool(llvm-stress
+ llvm-stress.cpp
+ )