summaryrefslogtreecommitdiff
path: root/tools/lto/CMakeLists.txt
diff options
context:
space:
mode:
authorShuxin Yang <shuxin.llvm@gmail.com>2013-08-12 18:29:43 +0000
committerShuxin Yang <shuxin.llvm@gmail.com>2013-08-12 18:29:43 +0000
commit67d135ae40b121a138e334a175d0e02dbb54eeca (patch)
tree8e7ef892ab3d66802b5f53af56ba6a36a5911742 /tools/lto/CMakeLists.txt
parent353476cbbb80881a754a90abc13851a884a4e26c (diff)
downloadllvm-67d135ae40b121a138e334a175d0e02dbb54eeca.tar.gz
llvm-67d135ae40b121a138e334a175d0e02dbb54eeca.tar.bz2
llvm-67d135ae40b121a138e334a175d0e02dbb54eeca.tar.xz
Misc enhancements to LTO:
1. Add some helper classes for partitions. They are designed in a way such that the top-level LTO driver will not see much difference with or without partitioning. 2. Introduce work-dir. Now all intermediate files generated during LTO phases will be saved under work-dir. User can specify the workdir via -lto-workdir=/path/to/dir. By default the work-dir will be erased before linker exit. To keep the workdir, do -lto-keep, or -lto-keep=1. TODO: Erase the workdir, if the linker exit prematurely. We are currently not able to remove directory on signal. The support routines simply ignore directory. 3. Add one new API lto_codegen_get_files_need_remove(). Linker and LTO plugin will communicate via this API about which files (including directories) need to removed before linker exit. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@188188 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/lto/CMakeLists.txt')
-rw-r--r--tools/lto/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/lto/CMakeLists.txt b/tools/lto/CMakeLists.txt
index 5820b1415b..7667449a34 100644
--- a/tools/lto/CMakeLists.txt
+++ b/tools/lto/CMakeLists.txt
@@ -9,6 +9,8 @@ set(SOURCES
LTODisassembler.cpp
lto.cpp
LTOModule.cpp
+ LTOPartition.cpp
+ LTOPostIPODriver.cpp
)
set(LLVM_COMMON_DEPENDS intrinsics_gen)