summaryrefslogtreecommitdiff
path: root/tools/opt/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael Espindola <rafael.espindola@gmail.com>2013-04-04 01:01:32 +0000
committerRafael Espindola <rafael.espindola@gmail.com>2013-04-04 01:01:32 +0000
commit436633e2a281ff620f2f4d9a06b33d3a99924717 (patch)
tree667d1785d2db75b65efa3458428c90af5d022513 /tools/opt/CMakeLists.txt
parente3d75ee2a1c8ea11fd01fc49055d08f2da7f5668 (diff)
downloadllvm-436633e2a281ff620f2f4d9a06b33d3a99924717.tar.gz
llvm-436633e2a281ff620f2f4d9a06b33d3a99924717.tar.bz2
llvm-436633e2a281ff620f2f4d9a06b33d3a99924717.tar.xz
Don't export symbols in every binary on linux.
On freebsd this makes sure that symbols are exported on the binaries that need them. The net result is that we should get symbols in the binaries that need them on every platform. On linux x86-64 this reduces the size of the bin directory from 262MB to 250MB. Patch by Stephen Checkoway. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@178725 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'tools/opt/CMakeLists.txt')
-rw-r--r--tools/opt/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/opt/CMakeLists.txt b/tools/opt/CMakeLists.txt
index 1ff8efbed0..91959119e4 100644
--- a/tools/opt/CMakeLists.txt
+++ b/tools/opt/CMakeLists.txt
@@ -6,3 +6,4 @@ add_llvm_tool(opt
PrintSCC.cpp
opt.cpp
)
+set_target_properties(opt PROPERTIES ENABLE_EXPORTS 1)