summaryrefslogtreecommitdiff
path: root/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorBenjamin Kramer <benny.kra@googlemail.com>2012-06-17 14:42:49 +0000
committerBenjamin Kramer <benny.kra@googlemail.com>2012-06-17 14:42:49 +0000
commit044de9c6f765d946abfd32b3f89a9033da5dd734 (patch)
tree741ab786cc8498403bcb21fbfe14b2a29fbce2da /unittests/CMakeLists.txt
parent1721b613109090fb790bc8707a11b1822608d1c8 (diff)
downloadllvm-044de9c6f765d946abfd32b3f89a9033da5dd734.tar.gz
llvm-044de9c6f765d946abfd32b3f89a9033da5dd734.tar.bz2
llvm-044de9c6f765d946abfd32b3f89a9033da5dd734.tar.xz
Add missing unittest files to the cmake build.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@158647 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/CMakeLists.txt')
-rw-r--r--unittests/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
index 1b6f55fca0..43896f57bb 100644
--- a/unittests/CMakeLists.txt
+++ b/unittests/CMakeLists.txt
@@ -73,6 +73,8 @@ add_llvm_unittest(ADT
ADT/IntervalMapTest.cpp
ADT/IntrusiveRefCntPtrTest.cpp
ADT/PackedVectorTest.cpp
+ ADT/SCCIteratorTest.cpp
+ ADT/SmallPtrSetTest.cpp
ADT/SmallStringTest.cpp
ADT/SmallVectorTest.cpp
ADT/SparseBitVectorTest.cpp
@@ -139,12 +141,12 @@ add_llvm_unittest(Transforms/Utils
set(VMCoreSources
VMCore/ConstantsTest.cpp
+ VMCore/DominatorTreeTest.cpp
VMCore/InstructionsTest.cpp
VMCore/MetadataTest.cpp
VMCore/PassManagerTest.cpp
VMCore/ValueMapTest.cpp
VMCore/VerifierTest.cpp
- VMCore/DominatorTreeTest.cpp
)
# MSVC9 and 8 cannot compile ValueMapTest.cpp due to their bug.
@@ -167,12 +169,18 @@ set(LLVM_LINK_COMPONENTS
add_llvm_unittest(Support
Support/AlignOfTest.cpp
Support/AllocatorTest.cpp
+ Support/BlockFrequencyTest.cpp
Support/Casting.cpp
Support/CommandLineTest.cpp
Support/ConstantRangeTest.cpp
+ Support/DataExtractorTest.cpp
Support/EndianTest.cpp
+ Support/IntegersSubsetTest.cpp
+ Support/IRBuilderTest.cpp
Support/LeakDetectorTest.cpp
+ Support/ManagedStatic.cpp
Support/MathExtrasTest.cpp
+ Support/MDBuilderTest.cpp
Support/Path.cpp
Support/raw_ostream_test.cpp
Support/RegexTest.cpp