summaryrefslogtreecommitdiff
path: root/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorNAKAMURA Takumi <geek4civic@gmail.com>2010-11-19 03:19:32 +0000
committerNAKAMURA Takumi <geek4civic@gmail.com>2010-11-19 03:19:32 +0000
commit130a2dd3c60e17b6bac054e3adf69205bf37afae (patch)
treeaca8902d93c4bf59958a8573d301b298df249855 /unittests/CMakeLists.txt
parentfb4d9816e79af3562e277631878b1a632bbcd8e1 (diff)
downloadllvm-130a2dd3c60e17b6bac054e3adf69205bf37afae.tar.gz
llvm-130a2dd3c60e17b6bac054e3adf69205bf37afae.tar.bz2
llvm-130a2dd3c60e17b6bac054e3adf69205bf37afae.tar.xz
unittests/CMakeLists.txt: Suppress building ValueMapTest on MSVC older than 10(VS2010).
MSVC9 and 8 cannot compile ValueMapTest.cpp due to their bug. See issue#331418 in Visual Studio. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@119782 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/CMakeLists.txt')
-rw-r--r--unittests/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
index 36aace5bc4..1e8f25a5f0 100644
--- a/unittests/CMakeLists.txt
+++ b/unittests/CMakeLists.txt
@@ -74,7 +74,7 @@ add_llvm_unittest(Transforms
Transforms/Utils/Cloning.cpp
)
-add_llvm_unittest(VMCore
+set(VMCoreSources
VMCore/ConstantsTest.cpp
VMCore/DerivedTypesTest.cpp
VMCore/InstructionsTest.cpp
@@ -84,6 +84,14 @@ add_llvm_unittest(VMCore
VMCore/VerifierTest.cpp
)
+# MSVC9 and 8 cannot compile ValueMapTest.cpp due to their bug.
+# See issue#331418 in Visual Studio.
+if(MSVC AND MSVC_VERSION LESS 1600)
+ list(REMOVE_ITEM VMCoreSources VMCore/ValueMapTest.cpp)
+endif()
+
+add_llvm_unittest(VMCore ${VMCoreSources})
+
set(LLVM_LINK_COMPONENTS
System
Support