summaryrefslogtreecommitdiff
path: root/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Klimek <klimek@google.com>2012-01-31 19:58:34 +0000
committerManuel Klimek <klimek@google.com>2012-01-31 19:58:34 +0000
commit41aa108f743ed3b97cdf060ae25cfef38af5bc9e (patch)
treeb6c61b9c7bc5cf54dd57b7297e5ac507928b6870 /unittests/CMakeLists.txt
parent57cae881e2b6c85a562d3fd2a7f10bf9d7921b40 (diff)
downloadllvm-41aa108f743ed3b97cdf060ae25cfef38af5bc9e.tar.gz
llvm-41aa108f743ed3b97cdf060ae25cfef38af5bc9e.tar.bz2
llvm-41aa108f743ed3b97cdf060ae25cfef38af5bc9e.tar.xz
RefCountedBaseVPTR needs the IntrusiveRefCntPtrInfo as friend,
now that this handles the release / retain calls. Adds a regression test for that bug (which is a compile-time regression) and for the last two changes to the IntrusiveRefCntPtr, especially tests for the memory leak due to copy construction of the ref-counted object and ensuring that the traits are used for release / retain calls. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@149411 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/CMakeLists.txt')
-rw-r--r--unittests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
index 6724f2df83..977efd790b 100644
--- a/unittests/CMakeLists.txt
+++ b/unittests/CMakeLists.txt
@@ -64,6 +64,7 @@ add_llvm_unittest(ADT
ADT/ImmutableSetTest.cpp
ADT/IntEqClassesTest.cpp
ADT/IntervalMapTest.cpp
+ ADT/IntrusiveRefCntPtrTest.cpp
ADT/PackedVectorTest.cpp
ADT/SmallBitVectorTest.cpp
ADT/SmallStringTest.cpp