summaryrefslogtreecommitdiff
path: root/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2012-06-21 01:35:09 +0000
committerChandler Carruth <chandlerc@gmail.com>2012-06-21 01:35:09 +0000
commit45df6f9e0401903b9eba84e2f90674b0a0dfea56 (patch)
tree4d126c4d2c3674354bbc067cada3ea9bf03bc38f /unittests/CMakeLists.txt
parent71b49cb5c73ba912f2fab30f35ed1e43c35a2139 (diff)
downloadllvm-45df6f9e0401903b9eba84e2f90674b0a0dfea56.tar.gz
llvm-45df6f9e0401903b9eba84e2f90674b0a0dfea56.tar.bz2
llvm-45df6f9e0401903b9eba84e2f90674b0a0dfea56.tar.xz
Remove one of the LLVM-specific CMake hacks in favor of standard CMake
facilities. This was only used in one place in LLVM, and was used pervasively (but with different code!) in Clang. It has no advantages over the standard CMake facilities and in some cases disadvantages. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@158889 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/CMakeLists.txt')
-rw-r--r--unittests/CMakeLists.txt13
1 files changed, 7 insertions, 6 deletions
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
index 43896f57bb..6af095e920 100644
--- a/unittests/CMakeLists.txt
+++ b/unittests/CMakeLists.txt
@@ -10,7 +10,14 @@ function(add_llvm_unittest test_dirname)
if( NOT LLVM_BUILD_TESTS )
set(EXCLUDE_FROM_ALL ON)
endif()
+
add_llvm_executable(${test_name}Tests ${ARGN})
+ target_link_libraries(${test_name}Tests
+ gtest
+ gtest_main
+ LLVMSupport # gtest needs it for raw_ostream.
+ )
+
add_dependencies(UnitTests ${test_name}Tests)
set_target_properties(${test_name}Tests PROPERTIES FOLDER "Tests")
endfunction()
@@ -51,12 +58,6 @@ set(LLVM_LINK_COMPONENTS
Support
)
-set(LLVM_USED_LIBS
- gtest
- gtest_main
- LLVMSupport # gtest needs it for raw_ostream.
- )
-
add_llvm_unittest(ADT
ADT/APFloatTest.cpp
ADT/APIntTest.cpp