summaryrefslogtreecommitdiff
path: root/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorJakob Stoklund Olesen <stoklund@2pi.dk>2012-02-22 00:56:08 +0000
committerJakob Stoklund Olesen <stoklund@2pi.dk>2012-02-22 00:56:08 +0000
commit62588622d40f6c6f5508496db69e06593b615049 (patch)
tree71c0226264aba20709e72a0be48064d51dc8418e /unittests/CMakeLists.txt
parent5990bd7ba645d6fd067d9f015f4f48a9b8bf872b (diff)
downloadllvm-62588622d40f6c6f5508496db69e06593b615049.tar.gz
llvm-62588622d40f6c6f5508496db69e06593b615049.tar.bz2
llvm-62588622d40f6c6f5508496db69e06593b615049.tar.xz
Add a Briggs and Torczon sparse set implementation.
For objects that can be identified by small unsigned keys, SparseSet provides constant time clear() and fast deterministic iteration. Insert, erase, and find operations are typically faster than hash tables. SparseSet is useful for keeping information about physical registers, virtual registers, or numbered basic blocks. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@151110 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/CMakeLists.txt')
-rw-r--r--unittests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
index 8420cd4e10..c6a904ee45 100644
--- a/unittests/CMakeLists.txt
+++ b/unittests/CMakeLists.txt
@@ -71,6 +71,7 @@ add_llvm_unittest(ADT
ADT/SmallStringTest.cpp
ADT/SmallVectorTest.cpp
ADT/SparseBitVectorTest.cpp
+ ADT/SparseSetTest.cpp
ADT/StringMapTest.cpp
ADT/StringRefTest.cpp
ADT/TripleTest.cpp