summaryrefslogtreecommitdiff
path: root/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2012-01-02 09:19:48 +0000
committerChandler Carruth <chandlerc@gmail.com>2012-01-02 09:19:48 +0000
commit972cc0d54ac9ddbaa4d22a4f36db5269b3b4bbde (patch)
treefc67ac35cd3847e50aff014f17c14fcc5ae994fa /unittests/CMakeLists.txt
parentc612d7981756fc379817840704c3d7416fa58892 (diff)
downloadllvm-972cc0d54ac9ddbaa4d22a4f36db5269b3b4bbde.tar.gz
llvm-972cc0d54ac9ddbaa4d22a4f36db5269b3b4bbde.tar.bz2
llvm-972cc0d54ac9ddbaa4d22a4f36db5269b3b4bbde.tar.xz
Undo the hack in r147427 and move this unittest to a better home. This
is testing the bitcode reader's functionality, not VMCore's. Add the what is a hope sufficient build system mojo to build and run a new unittest. Also clean up some of the test's naming. The goal for the file should be to unittest the Bitcode Reader, and this is just one particular test among potentially many in the future. Also, reverse my position and relegate the PR# to a comment, but stash the comment on the same line as the test name so it doesn't get lost. This makes the code more self-documenting hopefully w/o losing track of the PR number. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@147431 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/CMakeLists.txt')
-rw-r--r--unittests/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
index 3cd7f2f051..6724f2df83 100644
--- a/unittests/CMakeLists.txt
+++ b/unittests/CMakeLists.txt
@@ -112,7 +112,6 @@ set(VMCoreSources
VMCore/PassManagerTest.cpp
VMCore/ValueMapTest.cpp
VMCore/VerifierTest.cpp
- VMCore/pr11677.cpp
)
# MSVC9 and 8 cannot compile ValueMapTest.cpp due to their bug.
@@ -123,6 +122,10 @@ endif()
add_llvm_unittest(VMCore ${VMCoreSources})
+add_llvm_unittest(Bitcode
+ Bitcode/BitReaderTest.cpp
+ )
+
set(LLVM_LINK_COMPONENTS
Support
Core