summaryrefslogtreecommitdiff
path: root/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2010-10-28 14:38:35 +0000
committerOscar Fuentes <ofv@wanadoo.es>2010-10-28 14:38:35 +0000
commitda9756365b0404cd127150594d0906e7f730a457 (patch)
tree66b53d940ff0f4c1b9f673e7030f449d25bab123 /unittests/CMakeLists.txt
parenta264f72d3fb9dec1427480fcf17ef3c746ea723a (diff)
downloadllvm-da9756365b0404cd127150594d0906e7f730a457.tar.gz
llvm-da9756365b0404cd127150594d0906e7f730a457.tar.bz2
llvm-da9756365b0404cd127150594d0906e7f730a457.tar.xz
Document LLVM_BUILD_TESTS, LLVM_INCLUDE_TESTS. New convenience target
UnitTests for building all the unit tests. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@117545 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/CMakeLists.txt')
-rw-r--r--unittests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/unittests/CMakeLists.txt b/unittests/CMakeLists.txt
index df51bf821f..a2eed42dc3 100644
--- a/unittests/CMakeLists.txt
+++ b/unittests/CMakeLists.txt
@@ -10,8 +10,11 @@ function(add_llvm_unittest test_name)
set(EXCLUDE_FROM_ALL ON)
endif()
add_llvm_executable(${test_name}Tests ${ARGN})
+ add_dependencies(UnitTests ${test_name}Tests)
endfunction()
+add_custom_target(UnitTests)
+
include_directories(${LLVM_MAIN_SRC_DIR}/utils/unittest/googletest/include)
set(LLVM_REQUIRES_RTTI 1)
add_definitions(-DGTEST_HAS_RTTI=0)