summaryrefslogtreecommitdiff
path: root/unittests/ExecutionEngine/CMakeLists.txt
diff options
context:
space:
mode:
authorJyotsna Verma <jverma@codeaurora.org>2013-03-28 03:38:29 +0000
committerJyotsna Verma <jverma@codeaurora.org>2013-03-28 03:38:29 +0000
commit9f41d224679a6b246a583b5dbb3a50635f4ff517 (patch)
tree563a992f9b5c3c78e15e69ec59c8ce7defeb6ea8 /unittests/ExecutionEngine/CMakeLists.txt
parentd957f957eee12cf26a7160e6015f0a7c2629904f (diff)
downloadllvm-9f41d224679a6b246a583b5dbb3a50635f4ff517.tar.gz
llvm-9f41d224679a6b246a583b5dbb3a50635f4ff517.tar.bz2
llvm-9f41d224679a6b246a583b5dbb3a50635f4ff517.tar.xz
Disable JIT/MCJIT tests in unittests/ExecutionEngine for the targets that don't support JIT.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@178221 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/ExecutionEngine/CMakeLists.txt')
-rw-r--r--unittests/ExecutionEngine/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/unittests/ExecutionEngine/CMakeLists.txt b/unittests/ExecutionEngine/CMakeLists.txt
index ed7f10a23c..4eefc1e3bb 100644
--- a/unittests/ExecutionEngine/CMakeLists.txt
+++ b/unittests/ExecutionEngine/CMakeLists.txt
@@ -6,5 +6,9 @@ add_llvm_unittest(ExecutionEngineTests
ExecutionEngineTest.cpp
)
-add_subdirectory(JIT)
-add_subdirectory(MCJIT)
+# Include JIT/MCJIT tests only if native arch is a JIT target.
+list(FIND LLVM_TARGETS_WITH_JIT "${LLVM_NATIVE_ARCH}" have_jit)
+if (NOT have_jit EQUAL -1 )
+ add_subdirectory(JIT)
+ add_subdirectory(MCJIT)
+endif()