summaryrefslogtreecommitdiff
path: root/unittests/IR/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2014-03-04 12:46:06 +0000
committerChandler Carruth <chandlerc@gmail.com>2014-03-04 12:46:06 +0000
commit8f124fe88409b444fc3139b38423e3a61d4095dd (patch)
treef6ee25edcc2efea63936a9c8e69ae60b0203cb1f /unittests/IR/CMakeLists.txt
parent11d95df9b000c83456d7d147d800590f99242ace (diff)
downloadllvm-8f124fe88409b444fc3139b38423e3a61d4095dd.tar.gz
llvm-8f124fe88409b444fc3139b38423e3a61d4095dd.tar.bz2
llvm-8f124fe88409b444fc3139b38423e3a61d4095dd.tar.xz
[Modules] Move the LeakDetector header into the IR library where the
source file had already been moved. Also move the unittest into the IR unittest library. This may seem an odd thing to put in the IR library but we only really use this with instructions and it needs the LLVM context to work, so it is intrinsically tied to the IR library. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@202842 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/IR/CMakeLists.txt')
-rw-r--r--unittests/IR/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/unittests/IR/CMakeLists.txt b/unittests/IR/CMakeLists.txt
index e1c295d0be..7368a24051 100644
--- a/unittests/IR/CMakeLists.txt
+++ b/unittests/IR/CMakeLists.txt
@@ -13,6 +13,7 @@ set(IRSources
DominatorTreeTest.cpp
IRBuilderTest.cpp
InstructionsTest.cpp
+ LeakDetectorTest.cpp
LegacyPassManagerTest.cpp
MDBuilderTest.cpp
MetadataTest.cpp