summaryrefslogtreecommitdiff
path: root/unittests/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorReid Kleckner <reid@kleckner.net>2013-04-22 19:03:55 +0000
committerReid Kleckner <reid@kleckner.net>2013-04-22 19:03:55 +0000
commit0b675d88309bdcbb387bbee907c4ef9d98e412a2 (patch)
treea0cb0b64341e572f825489c0c58d41782ed5d517 /unittests/Support/CMakeLists.txt
parent4974b972e7dd94fad74ada4df32a12aba09c4de0 (diff)
downloadllvm-0b675d88309bdcbb387bbee907c4ef9d98e412a2.tar.gz
llvm-0b675d88309bdcbb387bbee907c4ef9d98e412a2.tar.bz2
llvm-0b675d88309bdcbb387bbee907c4ef9d98e412a2.tar.xz
[Support] Fix argv string escape bug on Windows
Summary: This is http://llvm.org/PR15802. Backslashes preceding double quotes in arguments must be escaped. The interesting bit is that all other backslashes should *not* be escaped, because the un-escaping logic is only triggered by the presence of a double quote character. Reviewers: Bigcheese CC: llvm-commits Differential Revision: http://llvm-reviews.chandlerc.com/D705 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@180035 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/Support/CMakeLists.txt')
-rw-r--r--unittests/Support/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/unittests/Support/CMakeLists.txt b/unittests/Support/CMakeLists.txt
index b4b982f2ef..a5bf3aef62 100644
--- a/unittests/Support/CMakeLists.txt
+++ b/unittests/Support/CMakeLists.txt
@@ -23,6 +23,7 @@ add_llvm_unittest(SupportTests
MemoryTest.cpp
Path.cpp
ProcessTest.cpp
+ ProgramTest.cpp
RegexTest.cpp
SwapByteOrderTest.cpp
TimeValue.cpp