summaryrefslogtreecommitdiff
path: root/unittests/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Kledzik <kledzik@apple.com>2012-08-01 02:29:50 +0000
committerNick Kledzik <kledzik@apple.com>2012-08-01 02:29:50 +0000
commitadfe2637b839efe041165f27c9ad57e3befb2be0 (patch)
tree4a2e92d6d1eb2d3c85b8b8669b3c186baaed2b56 /unittests/Support/CMakeLists.txt
parentc15ad8517719a525ac3b88b6c49b451160691eaa (diff)
downloadllvm-adfe2637b839efe041165f27c9ad57e3befb2be0.tar.gz
llvm-adfe2637b839efe041165f27c9ad57e3befb2be0.tar.bz2
llvm-adfe2637b839efe041165f27c9ad57e3befb2be0.tar.xz
Initial commit of new FileOutputBuffer support class.
Since the llvm::sys::fs::map_file_pages() support function it relies on is not yet implemented on Windows, the unit tests for FileOutputBuffer are currently conditionalized to run only on unix. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@161099 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/Support/CMakeLists.txt')
-rw-r--r--unittests/Support/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/unittests/Support/CMakeLists.txt b/unittests/Support/CMakeLists.txt
index 88596787dd..3b9bf84370 100644
--- a/unittests/Support/CMakeLists.txt
+++ b/unittests/Support/CMakeLists.txt
@@ -12,6 +12,7 @@ add_llvm_unittest(SupportTests
ConstantRangeTest.cpp
DataExtractorTest.cpp
EndianTest.cpp
+ FileOutputBufferTest.cpp
IntegersSubsetTest.cpp
LeakDetectorTest.cpp
ManagedStatic.cpp