summaryrefslogtreecommitdiff
path: root/unittests/Support/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Kornienko <alexfh@google.com>2013-08-07 00:07:07 +0000
committerAlexander Kornienko <alexfh@google.com>2013-08-07 00:07:07 +0000
commitece0bec0c824e71f062656ed5c727baf2a7bfc90 (patch)
treea60c6a3b376085470d329dca710518c256eb7f4e /unittests/Support/CMakeLists.txt
parentf65993999079bcde7b04373eca9ffa2be0e7ffe9 (diff)
downloadllvm-ece0bec0c824e71f062656ed5c727baf2a7bfc90.tar.gz
llvm-ece0bec0c824e71f062656ed5c727baf2a7bfc90.tar.bz2
llvm-ece0bec0c824e71f062656ed5c727baf2a7bfc90.tar.xz
Implemented llvm::sys::locale::columnWidth and isPrint for the case of generic UTF8-capable terminal.
Summary: This is a second attempt to get this right. After reading the Unicode Standard I came up with the code that uses definitions of "printable" and "column width" more suitable for terminal output (i.e. fixed-width fonts and special treatment of many control characters). The implementation here can probably be used for Windows and MacOS if someone can test it properly. The patch addresses PR14910. Reviewers: jordan_rose, gribozavr CC: llvm-commits Differential Revision: http://llvm-reviews.chandlerc.com/D1253 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@187837 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/Support/CMakeLists.txt')
-rw-r--r--unittests/Support/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/unittests/Support/CMakeLists.txt b/unittests/Support/CMakeLists.txt
index 2cbe730ef7..5f26d5d745 100644
--- a/unittests/Support/CMakeLists.txt
+++ b/unittests/Support/CMakeLists.txt
@@ -19,6 +19,7 @@ add_llvm_unittest(SupportTests
FileOutputBufferTest.cpp
IntegersSubsetTest.cpp
LeakDetectorTest.cpp
+ LocaleTest.cpp
ManagedStatic.cpp
MathExtrasTest.cpp
MD5Test.cpp