summaryrefslogtreecommitdiff
path: root/utils/TableGen/CMakeLists.txt
diff options
context:
space:
mode:
authorNate Begeman <natebegeman@mac.com>2010-05-28 01:08:32 +0000
committerNate Begeman <natebegeman@mac.com>2010-05-28 01:08:32 +0000
commit5ddb087f7fea1c4898d233a6cad6589d6f0a0b11 (patch)
tree318c709b3d77821a6e08284bdf10b8ca30a4cd5a /utils/TableGen/CMakeLists.txt
parent13ef8408073e00d3ae04067deee79721c62af209 (diff)
downloadllvm-5ddb087f7fea1c4898d233a6cad6589d6f0a0b11.tar.gz
llvm-5ddb087f7fea1c4898d233a6cad6589d6f0a0b11.tar.bz2
llvm-5ddb087f7fea1c4898d233a6cad6589d6f0a0b11.tar.xz
Add support to tablegen for auto-generating arm_neon.h from a tablegen description
of the intrinsics. The goal is to auto-generate both support for GCC-style (vector) and ARM-style (struct of vector) intrinsics. This is work in progress, but will be completed soon. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@104910 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'utils/TableGen/CMakeLists.txt')
-rw-r--r--utils/TableGen/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/utils/TableGen/CMakeLists.txt b/utils/TableGen/CMakeLists.txt
index 731cde92cf..05520c147d 100644
--- a/utils/TableGen/CMakeLists.txt
+++ b/utils/TableGen/CMakeLists.txt
@@ -22,6 +22,7 @@ add_executable(tblgen
InstrInfoEmitter.cpp
IntrinsicEmitter.cpp
LLVMCConfigurationEmitter.cpp
+ NeonEmitter.cpp
OptParserEmitter.cpp
Record.cpp
RegisterInfoEmitter.cpp