summaryrefslogtreecommitdiff
path: root/utils/TableGen/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Lattner <sabre@nondot.org>2010-02-15 08:04:42 +0000
committerChris Lattner <sabre@nondot.org>2010-02-15 08:04:42 +0000
commitda272d1a704bd564272e88cbdbcf14712e3abbdc (patch)
tree0f0a021cb55a151c44523e3f593bbc347f3e7e7a /utils/TableGen/CMakeLists.txt
parent9f06cb4fe5214c93cbe68b5359b43891875b30e5 (diff)
downloadllvm-da272d1a704bd564272e88cbdbcf14712e3abbdc.tar.gz
llvm-da272d1a704bd564272e88cbdbcf14712e3abbdc.tar.bz2
llvm-da272d1a704bd564272e88cbdbcf14712e3abbdc.tar.xz
Check in the first big step of rewriting DAGISelEmitter to
produce a table based matcher instead of gobs of C++ Code. Though it's not done yet, the shrinkage seems promising, the table for the X86 ISel is 75K and still has a lot of optimization to come (compare to the ~1.5M of .o generated the old way, much of which will go away). The code is currently disabled by default (the #if 0 in DAGISelEmitter.cpp). When enabled it generates a dead SelectCode2 function in the DAGISel Header which will eventually replace SelectCode. There is still a lot of stuff left to do, which are documented with a trail of FIXMEs. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@96215 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'utils/TableGen/CMakeLists.txt')
-rw-r--r--utils/TableGen/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/utils/TableGen/CMakeLists.txt b/utils/TableGen/CMakeLists.txt
index f344b28842..a2678a29f7 100644
--- a/utils/TableGen/CMakeLists.txt
+++ b/utils/TableGen/CMakeLists.txt
@@ -9,6 +9,9 @@ add_executable(tblgen
CodeGenInstruction.cpp
CodeGenTarget.cpp
DAGISelEmitter.cpp
+ DAGISelMatcherEmitter.cpp
+ DAGISelMatcherGen.cpp
+ DAGISelMatcher.cpp
DisassemblerEmitter.cpp
EDEmitter.cpp
FastISelEmitter.cpp